SleekFlow - Disruptions in accessing the SleekFlow platform (Web & Mobile App) due to Microsoft's outage – Incident details

All systems operational

Disruptions in accessing the SleekFlow platform (Web & Mobile App) due to Microsoft's outage

Resolved
Major outage
Started 20 days agoLasted about 3 hours

Affected

Web App

Major outage from 7:25 AM to 10:05 AM

API

Major outage from 7:25 AM to 10:05 AM

Mobile App

Major outage from 7:25 AM to 10:05 AM

Updates
  • Resolved
    Resolved

    We can confirm the disruptions have been fully resolved.


    Thank you for your patience.

  • Monitoring
    Monitoring

    Updated on 14 Nov 2025 at 03:39 PM HKT


    The team has applied mitigations, and the disruption is recovering.

    We will continue to monitor the status and provide updates as more information becomes available.

  • Investigating
    Investigating

    Microsoft has informed us that Azure is experiencing a service disruption since 14 Nov 2025 at 02:57 PM HKT.

    This issue from Microsoft could potentially affect some users’ access to SleekFlow, including logging in, loading, sending, and receiving messages.

    We are maintaining close communication with Microsoft’s team to investigate the issue, and will provide updates as soon as we receive them from the team.